[webkit-reviews] review granted: [Bug 180340] Improve FontSelectionAlgorithm, including moving from IntegerHasher to Hasher : [Attachment 328917] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Dec 10 00:34:14 PST 2017


Daniel Bates <dbates at webkit.org> has granted Darin Adler <darin at apple.com>'s
request for review:
Bug 180340: Improve FontSelectionAlgorithm, including moving from IntegerHasher
to Hasher
https://bugs.webkit.org/show_bug.cgi?id=180340

Attachment 328917: Patch

https://bugs.webkit.org/attachment.cgi?id=328917&action=review




--- Comment #11 from Daniel Bates <dbates at webkit.org> ---
Comment on attachment 328917
  --> https://bugs.webkit.org/attachment.cgi?id=328917
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=328917&action=review

I like this patch, including the improved naming, comments and use of “using “
to make this code more readable and hackable.

>>> Source/WebCore/platform/graphics/FontSelectionAlgorithm.h:98
>>> +	 static const FontSelectionValue
result(std::numeric_limits<BackingType>::max(), RawTag::RawTag);
>> 
>> No love for uniform initializer syntax?
> 
> I’ll try switching to that. In this case there might be a problem because
RawTag takes an int and the value of expression is a short.

If we made RawTag a regular enum as opposed to an enum class then we could drop
the enum class name qualifier :/

> Source/WebCore/platform/graphics/FontSelectionAlgorithm.h:334
> +    // FIXME: This name is no so great. Move this into the add function
below

no  => not


More information about the webkit-reviews mailing list