[webkit-reviews] review granted: [Bug 175621] [WebCrypto] Push WorkQueue dispatches for RSA algorithms into shared code : [Attachment 318755] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Aug 24 09:26:45 PDT 2017


Darin Adler <darin at apple.com> has granted Zan Dobersek <zan at falconsigh.net>'s
request for review:
Bug 175621: [WebCrypto] Push WorkQueue dispatches for RSA algorithms into
shared code
https://bugs.webkit.org/show_bug.cgi?id=175621

Attachment 318755: Patch

https://bugs.webkit.org/attachment.cgi?id=318755&action=review




--- Comment #18 from Darin Adler <darin at apple.com> ---
Comment on attachment 318755
  --> https://bugs.webkit.org/attachment.cgi?id=318755
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=318755&action=review

This solution looks fine to me.

> Source/WebCore/crypto/CryptoAlgorithm.cpp:96
> +static void dispatchOperationImpl(WorkQueue& workQueue,
ScriptExecutionContext& context, ResultCallbackType&& callback,
CryptoAlgorithm::ExceptionCallback&& exceptionCallback, OperationType&&
operation)

I don’t really like "Impl" in this function template name. Maybe we can find a
word to use instead of the abbreviation "impl". Or we can just leave this in
the global namespace and call it as "WebCore::dispatchOperation". Or we can
call it dispatchAlgorithmOperation since it’s not a class member.


More information about the webkit-reviews mailing list