[webkit-reviews] review granted: [Bug 175745] Split the one SWServer::Connection into SWClientConnection and SWServer::Connection : [Attachment 318582] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Aug 21 10:37:17 PDT 2017


Andy Estes <aestes at apple.com> has granted Brady Eidson <beidson at apple.com>'s
request for review:
Bug 175745: Split the one SWServer::Connection into SWClientConnection and
SWServer::Connection
https://bugs.webkit.org/show_bug.cgi?id=175745

Attachment 318582: Patch

https://bugs.webkit.org/attachment.cgi?id=318582&action=review




--- Comment #6 from Andy Estes <aestes at apple.com> ---
Comment on attachment 318582
  --> https://bugs.webkit.org/attachment.cgi?id=318582
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=318582&action=review

I find it a little strange that these "Connection" classes are both
MessageSenders and MessageReceivers. It seems like we usually split these into
separate classes and don't use the word "ConnectIon" in the receivers. Just
something to think about.

> Source/WebCore/workers/service/server/SWClientConnection.cpp:36
> +#include <wtf/HashMap.h>
> +#include <wtf/HashSet.h>
> +#include <wtf/ThreadSafeRefCounted.h>

Two out of three of these are included in SWClientConnection.h

> Source/WebCore/workers/service/server/SWServer.cpp:65
> +    connection.rejectJobInClient(jobData.identifier, ExceptionData {
UnknownError, ASCIILiteral("serviceWorker job scheduling is not yet
implemented") });

NotSupportedError seems more appropriate. Doesn't really matter since it's
temporary code.


More information about the webkit-reviews mailing list