[webkit-reviews] review granted: [Bug 175704] Rename DataTransferAccessPolicy to match spec and refactor related node : [Attachment 318463] Fixed iOS builds

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Aug 17 21:19:22 PDT 2017


Wenson Hsieh <wenson_hsieh at apple.com> has granted Ryosuke Niwa
<rniwa at webkit.org>'s request for review:
Bug 175704: Rename DataTransferAccessPolicy to match spec and refactor related
node
https://bugs.webkit.org/show_bug.cgi?id=175704

Attachment 318463: Fixed iOS builds

https://bugs.webkit.org/attachment.cgi?id=318463&action=review




--- Comment #3 from Wenson Hsieh <wenson_hsieh at apple.com> ---
Comment on attachment 318463
  --> https://bugs.webkit.org/attachment.cgi?id=318463
Fixed iOS builds

View in context: https://bugs.webkit.org/attachment.cgi?id=318463&action=review

> Source/WebCore/editing/Editor.cpp:331
> +	   storeMode = DataTransfer::StoreMode::Invalid;

Possibly helpful to ASSERT() that eventType is one of the other clipboard event
types here, that is not handled above?

> Source/WebCore/editing/Editor.cpp:346
> +	   pasteboard->writePasteboard(dataTransfer->pasteboard());

This reminds me -- we'll need to actually implement a lot of these methods on
iOS. Pasteboard::writePasteboard, for example, is stubbed out in
PasteboardIOS.mm

> Source/WebCore/page/DragController.cpp:233
> +    DragOperation srcOpMask = dragData.draggingSourceOperationMask();

I don't think this temporary variable adds much clarity.


More information about the webkit-reviews mailing list