[webkit-reviews] review granted: [Bug 175585] Support the 'with' keyword in FTL : [Attachment 318192] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Aug 15 16:19:29 PDT 2017


Saam Barati <sbarati at apple.com> has granted Robin Morisset
<rmorisset at apple.com>'s request for review:
Bug 175585: Support the 'with' keyword in FTL
https://bugs.webkit.org/show_bug.cgi?id=175585

Attachment 318192: Patch

https://bugs.webkit.org/attachment.cgi?id=318192&action=review




--- Comment #2 from Saam Barati <sbarati at apple.com> ---
Comment on attachment 318192
  --> https://bugs.webkit.org/attachment.cgi?id=318192
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=318192&action=review

> Source/JavaScriptCore/dfg/DFGByteCodeParser.cpp:5655
> +	       Node* scopeObject =
get(VirtualRegister(currentInstruction[3].u.operand));

FWIW, I think a less confusing variable name would just be "object" instead of
"scopeObject" here and in other places

> Source/JavaScriptCore/dfg/DFGFixupPhase.cpp:1713
> +	   case PushWithScope:

I think it's nice to document like before as KnownCellUse instead of CellUse.


More information about the webkit-reviews mailing list