[webkit-reviews] review granted: [Bug 175183] WebDriver: Implement page load strategy : [Attachment 317239] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Aug 4 11:12:52 PDT 2017


Brian Burg <bburg at apple.com> has granted Carlos Garcia Campos
<cgarcia at igalia.com>'s request for review:
Bug 175183: WebDriver: Implement page load strategy
https://bugs.webkit.org/show_bug.cgi?id=175183

Attachment 317239: Patch

https://bugs.webkit.org/attachment.cgi?id=317239&action=review




--- Comment #2 from Brian Burg <bburg at apple.com> ---
Comment on attachment 317239
  --> https://bugs.webkit.org/attachment.cgi?id=317239
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=317239&action=review

r=me, great work. Please send through EWS before landing.

> Source/WebKit/ChangeLog:8
> +	   Split pending navigation maps into normal and eager, and one or the
other depending on the received page load strategy.

Nit: ... and *use* one or the other ...

You don't actually say why two maps are needed here.

> Source/WebKit/UIProcess/Automation/WebAutomationSession.cpp:459
> +static void finishPendingNavigationsWithTimeoutFailure(HashMap<uint64_t,
RefPtr<Inspector::BackendDispatcher::CallbackBase>>& map)

Nit: I prefer a name like "respondToPendingNavigationCallbacksWithTimeout" or
something.

> Source/WebKit/UIProcess/Automation/WebAutomationSession.cpp:519
> +    Inspector::Protocol::Automation::PageLoadStrategy pageLoadStrategy =
defaultPageLoadStrategy;

Okay, we have this same code three times. Can you extract it?


More information about the webkit-reviews mailing list