[webkit-reviews] review granted: [Bug 174663] Web Inspector: add stack trace information for each RecordingAction : [Attachment 317015] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Aug 2 19:49:04 PDT 2017


Joseph Pecoraro <joepeck at webkit.org> has granted Devin Rousso
<drousso at apple.com>'s request for review:
Bug 174663: Web Inspector: add stack trace information for each RecordingAction
https://bugs.webkit.org/show_bug.cgi?id=174663

Attachment 317015: Patch

https://bugs.webkit.org/attachment.cgi?id=317015&action=review




--- Comment #12 from Joseph Pecoraro <joepeck at webkit.org> ---
Comment on attachment 317015
  --> https://bugs.webkit.org/attachment.cgi?id=317015
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=317015&action=review

r=me

> Source/JavaScriptCore/inspector/ScriptCallFrame.h:55
> +    bool operator==(const ScriptCallFrame& o) const { return isEqual(o); }

Style: Do not abbreviate names. Use `other`.

> Source/WebCore/inspector/InspectorCanvas.cpp:283
> +	       auto array = Inspector::Protocol::Array<double>::create();

Style: Just put `item =` here instead of the temp?

> Source/WebCore/inspector/InspectorCanvas.cpp:461
> +	       if (visitor->isNativeFrame() && !trace->length())

Style: Lets swap these for readability. Also a length check is probably
simpler.

> Source/WebInspectorUI/UserInterface/Models/RecordingAction.js:117
> +	       } catch (e) {
> +		   // Ignored.
> +	       }

You could be the first adopter of the parameterless catch!!

    try {
	...
    } catch { }


More information about the webkit-reviews mailing list