[webkit-reviews] review granted: [Bug 171280] Make DFG SpeculatedType dumps easier to read. : [Attachment 308114] proposed patch.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Apr 25 10:41:54 PDT 2017


Saam Barati <sbarati at apple.com> has granted Mark Lam <mark.lam at apple.com>'s
request for review:
Bug 171280: Make DFG SpeculatedType dumps easier to read.
https://bugs.webkit.org/show_bug.cgi?id=171280

Attachment 308114: proposed patch.

https://bugs.webkit.org/attachment.cgi?id=308114&action=review




--- Comment #2 from Saam Barati <sbarati at apple.com> ---
Comment on attachment 308114
  --> https://bugs.webkit.org/attachment.cgi?id=308114
proposed patch.

View in context: https://bugs.webkit.org/attachment.cgi?id=308114&action=review

> Source/JavaScriptCore/bytecode/SpeculatedType.cpp:63
> +struct PrettyPrinter {
> +    PrettyPrinter(PrintStream& out)
> +	   : out(out)
> +    { }
> +    
> +    template<typename T>
> +    void print(const T& value)
> +    {
> +	   if (!isFirst)
> +	       out.print("|");
> +	   out.print(value);
> +	   isFirst = false;
> +    }
> +    
> +    PrintStream& out;
> +    bool isFirst { true };
> +};

I think you can just use CommaPrinter with "|" as the input.


More information about the webkit-reviews mailing list