[webkit-reviews] review granted: [Bug 170250] AX: Modern Media Controls Timeline slider should be operable : [Attachment 307526] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Apr 20 01:40:51 PDT 2017


Antoine Quint <graouts at apple.com> has granted Aaron Chu <aaron_chu at apple.com>'s
request for review:
Bug 170250: AX: Modern Media Controls Timeline slider should be operable
https://bugs.webkit.org/show_bug.cgi?id=170250

Attachment 307526: Patch

https://bugs.webkit.org/attachment.cgi?id=307526&action=review




--- Comment #21 from Antoine Quint <graouts at apple.com> ---
Comment on attachment 307526
  --> https://bugs.webkit.org/attachment.cgi?id=307526
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=307526&action=review

> Source/WebCore/Modules/modern-media-controls/controls/scrubber.js:64
> +	   this._inputAccessibleLabel = this._formatTime(timeValue);

Doesn't look like we need this ivar at all.

> Source/WebCore/Modules/modern-media-controls/controls/slider.js:81
>	       this._handleInputEvent();

We should change the name of `_handleInputEvent()` now that it's called for
"change" events as well. We probably want it to be called something like
`_valueDidChange()`.

> Source/WebCore/Modules/modern-media-controls/controls/time-label.js:65
> +	   

Remove those extra lines.


More information about the webkit-reviews mailing list