[webkit-reviews] review granted: [Bug 170763] Resource Load Statistics: Check both origins and cookieHostNames for domain matches in data removal : [Attachment 307325] Patch
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Tue Apr 18 14:41:00 PDT 2017
Alex Christensen <achristensen at apple.com> has granted John Wilander
<wilander at apple.com>'s request for review:
Bug 170763: Resource Load Statistics: Check both origins and cookieHostNames
for domain matches in data removal
https://bugs.webkit.org/show_bug.cgi?id=170763
Attachment 307325: Patch
https://bugs.webkit.org/attachment.cgi?id=307325&action=review
--- Comment #10 from Alex Christensen <achristensen at apple.com> ---
Comment on attachment 307325
--> https://bugs.webkit.org/attachment.cgi?id=307325
Patch
View in context: https://bugs.webkit.org/attachment.cgi?id=307325&action=review
r=me
> Source/WebKit2/UIProcess/WebsiteData/WebsiteDataRecord.cpp:132
> + for (auto& dataRecordOriginData : origins) {
Can this be const auto&?
> Source/WebKit2/UIProcess/WebsiteData/WebsiteDataStore.cpp:507
> + if
(dataRecord.validForTopPrivatelyControlledDomain(topPrivatelyControlledDomain))
{
> + matchingDataRecords.append(WTFMove(dataRecord));
Maybe matchesTopPrivatelyControlledDomain would be a better name than
validForTopPrivatelyControlledDomain.
More information about the webkit-reviews
mailing list