[webkit-reviews] review granted: [Bug 170519] [MediaStream] Host application should be able to mute and unmute media streams : [Attachment 306323] Updated patch.
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Wed Apr 5 15:25:03 PDT 2017
youenn fablet <youennf at gmail.com> has granted Eric Carlson
<eric.carlson at apple.com>'s request for review:
Bug 170519: [MediaStream] Host application should be able to mute and unmute
media streams
https://bugs.webkit.org/show_bug.cgi?id=170519
Attachment 306323: Updated patch.
https://bugs.webkit.org/attachment.cgi?id=306323&action=review
--- Comment #6 from youenn fablet <youennf at gmail.com> ---
Comment on attachment 306323
--> https://bugs.webkit.org/attachment.cgi?id=306323
Updated patch.
View in context: https://bugs.webkit.org/attachment.cgi?id=306323&action=review
> Source/WebCore/Modules/mediastream/MediaStream.cpp:303
> + m_private->setExternallyMuted(document->page()->isMediaCaptureMuted());
What would be the difference between setExternallyMuted and setMuted?
Can we rename it to setMuted or setMediaCaptureMuted?
> Source/WebCore/dom/Document.cpp:2270
> + if (page() && m_mediaState != MediaProducer::IsNotPlaying) {
What does this change is covering?
> Source/WebCore/platform/mediastream/MediaStreamPrivate.cpp:138
> + track->stopProducingData();
Do we need to store m_externallyMuted in MediaStreamPrivate?
It seems like that muted is really a track thing.
s/m_externallyMuted/m_isExternallyMuted/ also?
> Source/WebCore/platform/mediastream/MediaStreamPrivate.cpp:195
> + m_externallyMuted = muted;
Why not calling setMuted directly to tracks without using m_externallyMuted?
More information about the webkit-reviews
mailing list