[webkit-reviews] review granted: [Bug 153796] [ES6] bound functions .name property should be "bound " + the target function's name : [Attachment 270522] patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Feb 2 14:49:00 PST 2016


Mark Lam <mark.lam at apple.com> has granted Saam Barati <sbarati at apple.com>'s
request for review:
Bug 153796: [ES6] bound functions .name property should be "bound " + the
target function's name
https://bugs.webkit.org/show_bug.cgi?id=153796

Attachment 270522: patch

https://bugs.webkit.org/attachment.cgi?id=270522&action=review




--- Comment #11 from Ryosuke Niwa <rniwa at webkit.org> ---
Comment on attachment 270522
  --> https://bugs.webkit.org/attachment.cgi?id=270522
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=270522&action=review

> Source/JavaScriptCore/runtime/JSBoundFunction.cpp:142
> +    String result = name(exec);
> +    ASSERT(result.find(ASCIILiteral(boundPrefix)) == 0);
> +    static const size_t boundPrefixLength = 6;
> +    return result.substring(boundPrefixLength);

Can't we just get the name out of m_targetFunction?


More information about the webkit-reviews mailing list