[webkit-reviews] review granted: [Bug 136826] Rename Node::nodeIndex() to computeNodeIndex() for clarity : [Attachment 238132] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Sep 16 00:35:34 PDT 2014


Benjamin Poulain <benjamin at webkit.org> has granted Chris Dumez
<cdumez at apple.com>'s request for review:
Bug 136826: Rename Node::nodeIndex() to computeNodeIndex() for clarity
https://bugs.webkit.org/show_bug.cgi?id=136826

Attachment 238132: Patch
https://bugs.webkit.org/attachment.cgi?id=238132&action=review

------- Additional Comments from Benjamin Poulain <benjamin at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=238132&action=review


I did not check the surrounding code, no need to change the type when the fix
is non obvious.

> Source/WebCore/dom/Range.cpp:603
> +    int nodeIndex = refNode->computeNodeIndex();

int -> unsigned?

> Source/WebCore/editing/ApplyStyleCommand.cpp:1294
> +	   int startOffsetAdjustment = startChild->computeNodeIndex();

ditto?

> Source/WebCore/editing/ApplyStyleCommand.cpp:1328
> +	   int endOffset = nextChild ? nextChild->computeNodeIndex() :
nextElement->countChildNodes();

ditto?

> Source/WebCore/editing/DeleteSelectionCommand.cpp:563
> +			       offset = n->computeNodeIndex() + 1;

ditto?

> Source/WebCore/editing/Editor.cpp:166
> +	   startOffset = element->computeNodeIndex();

ditto?

> Source/WebCore/editing/Editor.cpp:171
> +	   endOffset = element->computeNodeIndex();

ditto?

> Source/WebCore/editing/TextIterator.cpp:1098
> +	   int index = m_positionOffsetBaseNode->computeNodeIndex();

ditto?

> Source/WebCore/html/HTMLTextFormControlElement.cpp:427
> +	   offsetInContainer = node->computeNodeIndex() + offset;

ditto?

> Source/WebCore/page/DOMSelection.cpp:367
> +	   int offset = shadowAncestor->computeNodeIndex();

ditto?


More information about the webkit-reviews mailing list