[webkit-reviews] review granted: [Bug 136467] [iOS] Support using Foundation networking code : [Attachment 237522] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Sep 2 15:48:05 PDT 2014


Pratik Solanki <psolanki at apple.com> has granted Daniel Bates
<dbates at webkit.org>'s request for review:
Bug 136467: [iOS] Support using Foundation networking code
https://bugs.webkit.org/show_bug.cgi?id=136467

Attachment 237522: Patch
https://bugs.webkit.org/attachment.cgi?id=237522&action=review

------- Additional Comments from Pratik Solanki <psolanki at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=237522&action=review


I think I would prefer the platform name come first e.g.

    #if PLATFORM(IOS) && !USE(CFNETWORK) 

instead of

    #if !USE(CFNETWORK) && PLATFORM(IOS)

Seems easier to read for me. But what you have is fine as well if that is what
we use in other code.

> Source/WebCore/loader/ResourceLoader.cpp:583
> +#if USE(CF_NETWORK) && PLATFORM(IOS)

This should be USE(CFNETWORK)

> Source/WebCore/platform/network/mac/ResourceErrorMac.mm:38
>  #import <Foundation/NSURLError.h>

Not part of your patch, but I don't think we need this include anymore.
Foundation.h seems to include NSURLError.h.


More information about the webkit-reviews mailing list