[webkit-reviews] review granted: [Bug 137728] Have offsetFromContainer() / offsetFromAncestorContainer() take a RenderElement& : [Attachment 239843] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Oct 14 21:10:46 PDT 2014


Benjamin Poulain <benjamin at webkit.org> has granted Chris Dumez
<cdumez at apple.com>'s request for review:
Bug 137728: Have offsetFromContainer() / offsetFromAncestorContainer() take a
RenderElement&
https://bugs.webkit.org/show_bug.cgi?id=137728

Attachment 239843: Patch
https://bugs.webkit.org/attachment.cgi?id=239843&action=review

------- Additional Comments from Benjamin Poulain <benjamin at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=239843&action=review


rs=me

> Source/WebCore/rendering/RenderBox.cpp:1915
> +    auto* container = this->container(repaintContainer, &containerSkipped);

IMHO, "auto" is bad here, the type is 100% non obvious.

> Source/WebCore/rendering/RenderBox.cpp:1964
> +    auto* container = this->container(ancestorToStopAt, &ancestorSkipped);

ditto

> Source/WebCore/rendering/RenderBoxModelObject.cpp:2640
> +    auto* container = this->container();

ditto

> Source/WebCore/rendering/RenderObject.cpp:1874
> -	   auto nextContainer = currContainer->container();
> +	   auto* nextContainer = currContainer->container();

gosh I hate auto sometimes... It is just making code hard to follow :(


More information about the webkit-reviews mailing list