[webkit-reviews] review granted: [Bug 136150] [ATK] Changing the mapping of aria rowheader and columnheader into respective ATK roles. : [Attachment 239337] proposed patch 9

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Oct 8 09:16:30 PDT 2014


chris fleizach <cfleizach at apple.com> has granted Andrzej Badowski
<a.badowski at samsung.com>'s request for review:
Bug 136150: [ATK] Changing the mapping of aria rowheader and columnheader into
respective ATK roles.
https://bugs.webkit.org/show_bug.cgi?id=136150

Attachment 239337: proposed patch 9
https://bugs.webkit.org/attachment.cgi?id=239337&action=review

------- Additional Comments from chris fleizach <cfleizach at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=239337&action=review


> Source/WebCore/accessibility/AccessibilityRenderObject.cpp:2568
> +	   for (node = node->parentNode(); node; node = node->parentNode()) {

I think you should use a different variable for node, since you're using it it
everywhere else to reference the current node, but
then you're in this for loop, changing it to parent nodes.
I see that you don't leave this block, so there's probably not a logic problem,
but for readability it might be good to use

for (Node* parentNode = node->parentNode(); parentNode; parentNode =
parentNode->parentNode())


More information about the webkit-reviews mailing list