[webkit-reviews] review granted: [Bug 133365] Captions during HLS playback flash/are difficult to read : [Attachment 232223] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed May 28 18:47:06 PDT 2014


Eric Carlson <eric.carlson at apple.com> has granted Brent Fulgham
<bfulgham at webkit.org>'s request for review:
Bug 133365: Captions during HLS playback flash/are difficult to read
https://bugs.webkit.org/show_bug.cgi?id=133365

Attachment 232223: Patch
https://bugs.webkit.org/attachment.cgi?id=232223&action=review

------- Additional Comments from Eric Carlson <eric.carlson at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=232223&action=review


Thanks!

> Source/WebCore/html/track/DataCue.cpp:-131
> -    if (cue.cueType() != TextTrackCue::Data)
> -	   return false;
> -

Is it necessary to remove this? If so, how can it be safe given that we call
toDataCue() below (which will ASSERT if passed a non-datacue)?

> Source/WebCore/html/track/TextTrackCue.cpp:242
> +bool TextTrackCue::isStartOfCue(const TextTrackCue& cue) const

I am not wild about this name because I didn't know what it was supposed to
check until I found it and read the code. How about something like
"isCueExtension", or "extendsCue"? Or something else...


More information about the webkit-reviews mailing list