[webkit-reviews] review granted: [Bug 132917] remove duplicate code in web timing : [Attachment 231459] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed May 14 11:22:13 PDT 2014


Alexey Proskuryakov <ap at webkit.org> has granted Alex Christensen
<achristensen at apple.com>'s request for review:
Bug 132917: remove duplicate code in web timing
https://bugs.webkit.org/show_bug.cgi?id=132917

Attachment 231459: Patch
https://bugs.webkit.org/attachment.cgi?id=231459&action=review

------- Additional Comments from Alexey Proskuryakov <ap at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=231459&action=review


> Source/WebCore/platform/network/ResourceHandle.h:33
> +#include "ResourceLoadTiming.h"

Please don't include it, just forward declare.

> Source/WebCore/platform/network/ResourceHandle.h:134
> +    static void transferTimingData(NSURLConnection*, ResourceLoadTiming&);

I'd say "get", not "transfer".

> Source/WebCore/platform/network/mac/WebCoreResourceHandleAsDelegate.mm:175
> +    ResourceHandle::transferTimingData(connection,
resourceResponse.resourceLoadTiming());

This is not what I was thinking of - I think that a nicer way to implement this
would be to call into ResourceHandle here, which would then read the timing
data, and call the client. Duplicating even the
ResourceHandle::transferTimingData still leaves the potential for us to forget
about it in future reimplementations.

It's OK to land as is though, the patch is an improvement.


More information about the webkit-reviews mailing list