[webkit-reviews] review denied: [Bug 132846] ResourceLoadTiming should use reference instead of pointer : [Attachment 231386] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue May 13 13:57:44 PDT 2014


Anders Carlsson <andersca at apple.com> has denied Alex Christensen
<achristensen at apple.com>'s request for review:
Bug 132846: ResourceLoadTiming should use reference instead of pointer
https://bugs.webkit.org/show_bug.cgi?id=132846

Attachment 231386: Patch
https://bugs.webkit.org/attachment.cgi?id=231386&action=review

------- Additional Comments from Anders Carlsson <andersca at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=231386&action=review


Is there a reason why you can't just have an std::unique_ptr reference to the
ResourceLoadTiming object? Maybe it doesn't matter.
r- because of the assignment operator.

> Source/WebCore/platform/network/ResourceLoadTiming.h:65
> +    void operator=(const ResourceLoadTiming& other)
> +    {
> +	   domainLookupStart = other.domainLookupStart;
> +	   domainLookupEnd = other.domainLookupEnd;
> +	   connectStart = other.connectStart;
> +	   connectEnd = other.connectEnd;
> +	   requestStart = other.requestStart;
> +	   responseStart = other.responseStart;
> +	   secureConnectionStart = other.secureConnectionStart;
> +    }

This is not a correct assignment operator, it needs to return *this.

> Source/WebCore/platform/network/ResourceResponseBase.cpp:555
>      lazyInit(CommonAndUncommonFields);

Do we need to call this now?


More information about the webkit-reviews mailing list