[webkit-reviews] review denied: [Bug 130709] [iOS] Inspector View Indication Support : [Attachment 227716] [PATCH] Proposed Fix

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Mar 24 23:06:39 PDT 2014


Simon Fraser (smfr) <simon.fraser at apple.com> has denied  review:
Bug 130709: [iOS] Inspector View Indication Support
https://bugs.webkit.org/show_bug.cgi?id=130709

Attachment 227716: [PATCH] Proposed Fix
https://bugs.webkit.org/attachment.cgi?id=227716&action=review

------- Additional Comments from Simon Fraser (smfr) <simon.fraser at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=227716&action=review


> Source/WebKit2/UIProcess/API/Cocoa/WKWebView.mm:1097
> +- (void)_startIndicatingView

"indicatingView" is ambiguous and not really good English. It should be read as
-(UIView*)indicatingView, but I think you mean it as the view is "indicating
the state of being inspected".

How about showShowingInspectionIndication/indicator? Or
-(void)setIsShowingInspectionIndicator:(BOOL)?

> Source/WebKit2/UIProcess/PageClient.h:255
> +    virtual void startIndicatingView() = 0;
> +    virtual void stopIndicatingView() = 0;

Same bad naming.

> Source/WebKit2/UIProcess/ios/WKContentView.mm:64
> + at interface IndicateView : UIView

I think this class name should contain "inspector". It should have a prefix (WK
or Web?), maybe with an underscore. Web/WKInspectorIndicationView?


More information about the webkit-reviews mailing list