[webkit-reviews] review granted: [Bug 133764] make sdiv a template on armv7s to remove duplicate code in dfg : [Attachment 233074] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jun 18 09:27:30 PDT 2014


Daniel Bates <dbates at webkit.org> has granted Alex Christensen
<achristensen at apple.com>'s request for review:
Bug 133764: make sdiv a template on armv7s to remove duplicate code in dfg
https://bugs.webkit.org/show_bug.cgi?id=133764

Attachment 233074: Patch
https://bugs.webkit.org/attachment.cgi?id=233074&action=review

------- Additional Comments from Daniel Bates <dbates at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=233074&action=review


> Source/JavaScriptCore/assembler/ARMv7Assembler.h:1520
> +	   COMPILE_ASSERT(datasize == 32);	  

Does this compile? I mean, COMPILE_ASSERT() takes two arguments: a predicate
and a error message to be shown if the predicate evaluates to false. Moreover,
the blog post <https://www.webkit.org/blog/3172/webkit-and-cxx11/> implies that
we should explicitly use static_assert() in new C++ code instead of the
COMPILE_ASSERT() macro function (even though it calls through to
static_assert()) since we require ports to build WebKit with compilers that
supports the C++11 static_assert feature.


More information about the webkit-reviews mailing list