[webkit-reviews] review granted: [Bug 133759] Add LLVM FastISel abort option for coverage testing : [Attachment 232894] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jun 12 16:36:23 PDT 2014


Filip Pizlo <fpizlo at apple.com> has granted Juergen Ributzka
<juergen at apple.com>'s request for review:
Bug 133759: Add LLVM FastISel abort option for coverage testing
https://bugs.webkit.org/show_bug.cgi?id=133759

Attachment 232894: Patch
https://bugs.webkit.org/attachment.cgi?id=232894&action=review

------- Additional Comments from Filip Pizlo <fpizlo at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=232894&action=review


> Source/JavaScriptCore/llvm/InitializeLLVMPOSIX.cpp:38
> +typedef LLVMAPI* (*InitializerFunction)(void (*)(const char*, ...), bool
FastISelAbort);

Call it fastISelAbort

> Source/JavaScriptCore/llvm/library/LLVMExports.cpp:63
> +extern "C" JSC::LLVMAPI* initializeAndGetJSCLLVMAPI(void (*callback)(const
char*, ...), bool FastISelAbort)

Our naming convention would have this variable start with lower case:
fastISelAbort.


More information about the webkit-reviews mailing list