[webkit-reviews] review granted: [Bug 135195] Refactor EventHandler to call ScrollAnimator::handleWheelEvent for overflow scrolling : [Attachment 235721] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jul 30 15:31:34 PDT 2014


Beth Dakin <bdakin at apple.com> has granted Wenson Hsieh
<wenson_hsieh at apple.com>'s request for review:
Bug 135195: Refactor EventHandler to call ScrollAnimator::handleWheelEvent for
overflow scrolling
https://bugs.webkit.org/show_bug.cgi?id=135195

Attachment 235721: Patch
https://bugs.webkit.org/attachment.cgi?id=235721&action=review

------- Additional Comments from Beth Dakin <bdakin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=235721&action=review


Looks good!

> Source/WebCore/page/EventHandler.cpp:292
> +    return scrollableArea->scroll(delta < 0 ? negativeDirection :
positiveDirection,
wheelGranularityToScrollGranularity(wheelEvent->deltaMode()), delta > 0 ? delta
: -delta);

So much more readable!!


More information about the webkit-reviews mailing list