[webkit-reviews] review granted: [Bug 135101] Add helper functions to dump the scrolling state tree from the debugger : [Attachment 235185] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Jul 20 10:31:46 PDT 2014


Darin Adler <darin at apple.com> has granted Simon Fraser (smfr)
<simon.fraser at apple.com>'s request for review:
Bug 135101: Add helper functions to dump the scrolling state tree from the
debugger
https://bugs.webkit.org/show_bug.cgi?id=135101

Attachment 235185: Patch
https://bugs.webkit.org/attachment.cgi?id=235185&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=235185&action=review


> Source/WebCore/page/scrolling/ScrollingStateTree.cpp:39
> +#ifndef NDEBUG
> +#include <wtf/Text/CString.h>
> +#endif

I think we should just include this unconditionally.

> Source/WebCore/page/scrolling/ScrollingStateTree.cpp:254
> +#ifndef NDEBUG
> +void showScrollingStateTree(const WebCore::ScrollingStateTree* tree)

Please add a blank line here.

> Source/WebCore/page/scrolling/ScrollingStateTree.cpp:257
> +    if (!tree)
> +	   return;

Silent? Maybe print something for clarity?

> Source/WebCore/page/scrolling/ScrollingStateTree.cpp:259
> +    const WebCore::ScrollingStateNode* rootNode = tree->rootStateNode();

I would just do auto* here; the complete typename and const is utterly
uninteresting.

> Source/WebCore/page/scrolling/ScrollingStateTree.cpp:272
> +    if (!node)
> +	   return;

Silent? Maybe print something for clarity?

> Source/WebCore/page/scrolling/ScrollingStateTree.h:111
> +#ifndef NDEBUG
> +void showScrollingStateTree(const WebCore::ScrollingStateTree*);
> +void showScrollingStateTree(const WebCore::ScrollingStateNode*);
> +#endif

Does it really need to be in the header? Can’t we just put this at the top of
the .cpp file?


More information about the webkit-reviews mailing list