[webkit-reviews] review granted: [Bug 134759] [EFL][WK2] Add new Public API in ewk_download_job.h to get length of the data already downloaded : [Attachment 234628] Patch-Updated-Review

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jul 9 05:33:08 PDT 2014


Gyuyoung Kim <gyuyoung.kim at webkit.org> has granted Shivakumar J M
<shiva.jm at samsung.com>'s request for review:
Bug 134759: [EFL][WK2] Add new Public API in ewk_download_job.h to get length
of the data already downloaded
https://bugs.webkit.org/show_bug.cgi?id=134759

Attachment 234628: Patch-Updated-Review
https://bugs.webkit.org/attachment.cgi?id=234628&action=review

------- Additional Comments from Gyuyoung Kim <gyuyoung.kim at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=234628&action=review


LGTM except for minor nits.

> Source/WebKit2/UIProcess/API/efl/ewk_download_job.h:189
> + * @param download a #Ewk_Download_Job to query.

We haven't add period at @param and @return.

> Source/WebKit2/UIProcess/API/efl/ewk_download_job.h:191
> + * @return the length of the data already downloaded.

ditto.

> Source/WebKit2/UIProcess/API/efl/ewk_download_job.h:193
> +EAPI uint64_t ewk_download_job_received_data_length_get(const
Ewk_Download_Job *download);

Isn't "data_size" more proper for this API ?

> Source/WebKit2/UIProcess/API/efl/ewk_download_job_private.h:71
> +    uint64_t receivedData() const;

receivedDataSize() ?


More information about the webkit-reviews mailing list