[webkit-reviews] review granted: [Bug 134623] [iOS][WK2] Black web view after un-suspending process : [Attachment 234386] patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jul 3 22:10:16 PDT 2014


Simon Fraser (smfr) <simon.fraser at apple.com> has granted Tim Horton
<thorton at apple.com>'s request for review:
Bug 134623: [iOS][WK2] Black web view after un-suspending process
https://bugs.webkit.org/show_bug.cgi?id=134623

Attachment 234386: patch
https://bugs.webkit.org/attachment.cgi?id=234386&action=review

------- Additional Comments from Simon Fraser (smfr) <simon.fraser at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=234386&action=review


> Source/WebKit2/UIProcess/WebPageProxy.cpp:1107
> +    m_viewStateChangeWantsReply = (m_viewStateChangeWantsReply ==
WantsReplyOrNot::DoesWantReply || wantsReplyOrNot ==
WantsReplyOrNot::DoesWantReply) ? WantsReplyOrNot::DoesWantReply :
WantsReplyOrNot::DoesNotWantReply;

I feel like the enum is hurting readability in this code.

> Source/WebKit2/UIProcess/WebPageProxy.cpp:1176
>  #if ENABLE(INPUT_TYPE_COLOR_POPOVER)
> -	   // When leaving the current page, close the popover color well.
> -	   if (m_colorPicker)
> -	       endColorPicker();
> +	       // When leaving the current page, close the popover color well.
> +	       if (m_colorPicker)
> +		   endColorPicker();
>  #endif
>  #if PLATFORM(IOS)
> -	   // When leaving the current page, close the video fullscreen.
> -	   if (m_videoFullscreenManager)
> -	       m_videoFullscreenManager->requestHideAndExitFullscreen();
> +	       // When leaving the current page, close the video fullscreen.
> +	       if (m_videoFullscreenManager)
> +		   m_videoFullscreenManager->requestHideAndExitFullscreen();
>  #endif
> +	   }

Seems like these should be factored into a onLeavingWindow() or something.


More information about the webkit-reviews mailing list