[webkit-reviews] review granted: [Bug 134506] [iOS][WK2] Sometimes the swipe snapshot stays up too long : [Attachment 234293] patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jul 3 12:07:51 PDT 2014


Simon Fraser (smfr) <simon.fraser at apple.com> has granted Tim Horton
<thorton at apple.com>'s request for review:
Bug 134506: [iOS][WK2] Sometimes the swipe snapshot stays up too long
https://bugs.webkit.org/show_bug.cgi?id=134506

Attachment 234293: patch
https://bugs.webkit.org/attachment.cgi?id=234293&action=review

------- Additional Comments from Simon Fraser (smfr) <simon.fraser at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=234293&action=review


> Source/WebKit2/Shared/mac/RemoteLayerTreeTransaction.h:213
> +    typedef uint64_t TransactionCallbackID;

Very nice.

> Source/WebKit2/UIProcess/ios/ViewGestureControllerIOS.mm:68
> +static HashMap<uint64_t, WebKit::ViewGestureController*>&
allViewGestureControllers()

Please add a comment saying that the uint64_t is a pageID or rename this to
viewGestureControllersForAllPages()

> Source/WebKit2/UIProcess/ios/ViewGestureControllerIOS.mm:263
> +	   if (gestureControllerIter == allViewGestureControllers().end())
> +	       return;
> +	  
gestureControllerIter->value->willCommitPostSwipeTransitionLayerTree(error ==
CallbackBase::Error::None);

Would slightly prefer this as 
if (gestureControllerIter != allViewGestureControllers().end())
  gestureControllerIter->value->willCommitPostSwipeTransitionLayerTree(error ==
CallbackBase::Error::None);

> Source/WebKit2/UIProcess/mac/RemoteLayerTreeDrawingAreaProxy.mm:137
> +	   if (callback)

if (auto callback = m_callbacks.take<VoidCallback>(callbackID)) ?


More information about the webkit-reviews mailing list