[webkit-reviews] review granted: [Bug 127988] Add security-checked casts for all WebCore::CachedResource subclasses : [Attachment 222807] Patch v1

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Jan 31 12:12:22 PST 2014


Darin Adler <darin at apple.com> has granted David Kilzer (:ddkilzer)
<ddkilzer at webkit.org>'s request for review:
Bug 127988: Add security-checked casts for all WebCore::CachedResource
subclasses
https://bugs.webkit.org/show_bug.cgi?id=127988

Attachment 222807: Patch v1
https://bugs.webkit.org/attachment.cgi?id=222807&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=222807&action=review


>>> Source/WebCore/loader/cache/CachedResource.h:159
>>> +	 bool isRawResource() const { return type() == MainResource || type()
== RawResource; }
>> 
>> This looks ultra confusing.
> 
> Are you suggesting that a new method name is needed, or something else?
> 
> "This looks ultra confusing" is not an actionable comment.

I think the way to fix this is to put it in its own paragraph with a comment
explaining that CachedMainResource is derived from CachedRawResource.


More information about the webkit-reviews mailing list