[webkit-reviews] review granted: [Bug 127266] Add a nicer way to iterate over all the attributes of an element : [Attachment 221620] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jan 20 09:33:11 PST 2014


Geoffrey Garen <ggaren at apple.com> has granted Benjamin Poulain
<benjamin at webkit.org>'s request for review:
Bug 127266: Add a nicer way to iterate over all the attributes of an element
https://bugs.webkit.org/show_bug.cgi?id=127266

Attachment 221620: Patch
https://bugs.webkit.org/attachment.cgi?id=221620&action=review

------- Additional Comments from Geoffrey Garen <ggaren at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=221620&action=review


r=me

Please consider Anders's suggestion.

> Source/WebCore/dom/ElementData.cpp:182
> +    unsigned count = length();

In cases like this, I prefer "unsigned length = this->length()" or "unsigned
length = ElementData::length()". It's bad when one thing becomes two. Taking
"length" and renaming it to "count" makes it seem like you've changed it
somehow, which can be confusing.


More information about the webkit-reviews mailing list