[webkit-reviews] review granted: [Bug 126696] DocumentOrderedMap should use iterator : [Attachment 220738] better patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jan 9 08:50:51 PST 2014


Andreas Kling <akling at apple.com> has granted Antti Koivisto <koivisto at iki.fi>'s
request for review:
Bug 126696: DocumentOrderedMap should use iterator
https://bugs.webkit.org/show_bug.cgi?id=126696

Attachment 220738: better patch
https://bugs.webkit.org/attachment.cgi?id=220738&action=review

------- Additional Comments from Andreas Kling <akling at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=220738&action=review


> Source/WebCore/dom/DocumentOrderedMap.cpp:213
> +	   auto elementDescandants =
descendantsOfType<Element>(*scope.rootNode());

Typo, descandants.

> Source/WebCore/dom/DocumentOrderedMap.cpp:214
> +	   auto it = entry.element ? elementDescandants.find(*entry.element) :
elementDescandants.begin();

We need a better name for find(). beginAt()?


More information about the webkit-reviews mailing list