[webkit-reviews] review granted: [Bug 126527] Add write barriers to the LLInt : [Attachment 220450] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jan 6 13:11:41 PST 2014


Filip Pizlo <fpizlo at apple.com> has granted Mark Hahnenberg
<mhahnenberg at apple.com>'s request for review:
Bug 126527: Add write barriers to the LLInt
https://bugs.webkit.org/show_bug.cgi?id=126527

Attachment 220450: Patch
https://bugs.webkit.org/attachment.cgi?id=220450&action=review

------- Additional Comments from Filip Pizlo <fpizlo at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=220450&action=review


> Source/JavaScriptCore/llint/LowLevelInterpreter32_64.asm:494
> +macro writeBarrierOnOperand(cell)

Rename 'cell' to 'cellOperand' or something to indicate that we're talkinga
bout an operand number.

> Source/JavaScriptCore/llint/LowLevelInterpreter32_64.asm:515
> +macro writeBarrierOnOperands(cell, value)

Ditto, and then 'valueOperand'.

> Source/JavaScriptCore/llint/LowLevelInterpreter32_64.asm:526
> +macro writeBarrierOnGlobalObject(value)

'valueOperand'

> Source/JavaScriptCore/offlineasm/x86.rb:991
> +	   when "pushPBAndPC"
> +	       raise unless isX64
> +	       $asm.puts "pushq %r10"
> +	       $asm.puts "pushq %rsi"
> +	   when "popPBAndPC"
> +	       raise unless isX64
> +	       $asm.puts "popq %rsi"
> +	       $asm.puts "popq %r10"

Can you instead give push/pop a two-operand form?


More information about the webkit-reviews mailing list