[webkit-reviews] review granted: [Bug 126148] Support <box> values computed style for 'clip-path' property : [Attachment 220028] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jan 1 22:46:09 PST 2014


Simon Fraser (smfr) <simon.fraser at apple.com> has granted Dirk Schulze
<krit at webkit.org>'s request for review:
Bug 126148: Support <box> values computed style for 'clip-path' property
https://bugs.webkit.org/show_bug.cgi?id=126148

Attachment 220028: Patch
https://bugs.webkit.org/attachment.cgi?id=220028&action=review

------- Additional Comments from Simon Fraser (smfr) <simon.fraser at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=220028&action=review


> Source/WebCore/css/CSSComputedStyleDeclaration.cpp:2869
> +		   ReferenceClipPathOperation& referenceOperation =
*toReferenceClipPathOperation(operation);

I think it would be slightly better to say
ReferenceClipPathOperation& referenceOperation =
toReferenceClipPathOperation(*operation);

> Source/WebCore/css/CSSComputedStyleDeclaration.cpp:2875
> +		   ShapeClipPathOperation& shapeOperation =
*toShapeClipPathOperation(operation);

Ditto

> Source/WebCore/css/CSSComputedStyleDeclaration.cpp:2881
> +		   BoxClipPathOperation& boxOperation =
*toBoxClipPathOperation(operation);

Ditto

> Source/WebCore/rendering/ClipPathOperation.h:148
> +    const Path& path(const FloatRect&)

This is confusing. Is it going to return path that just contains the given
rect? Should it be called pathForRect()? Why does this change m_path?


More information about the webkit-reviews mailing list