[webkit-reviews] review granted: [Bug 128631] [CSS Shapes] shape-outside does not properly handle different writing modes : [Attachment 224255] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Feb 18 11:54:02 PST 2014


Dave Hyatt <hyatt at apple.com> has granted Bem Jones-Bey <bjonesbe at adobe.com>'s
request for review:
Bug 128631: [CSS Shapes] shape-outside does not properly handle different
writing modes
https://bugs.webkit.org/show_bug.cgi?id=128631

Attachment 224255: Patch
https://bugs.webkit.org/attachment.cgi?id=224255&action=review

------- Additional Comments from Dave Hyatt <hyatt at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=224255&action=review


r=me with a rename suggestion.

> Source/WebCore/rendering/RenderBoxModelObject.h:121
> +    virtual LayoutUnit borderWidth() const { return borderLeft() +
borderRight(); }
> +    virtual LayoutUnit borderHeight() const { return borderTop() +
borderBottom(); }

I would suggest naming these horizontalBorderExtent and verticalBorderExtent. I
dislike using terms like "width" since it could be confused with the actual
border-width CSS name, i.e., a person new to this code would think the method
was returning the pixel width of a single border.

I think renaming all of the other functions would be good too, i.e.,
marginWidth = horizontalMarginExtent, marginHeight = verticalMarginExtent, etc.


borderAndPaddingWidth could be horizontalBorderAndPaddingExtent, and then
borderAndPaddingHeight could be verticalBorderAndPaddingExtent.


More information about the webkit-reviews mailing list