[webkit-reviews] review requested: [Bug 128560] Fail FTL compilation if the required stack is too big : [Attachment 223765] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 10 16:34:33 PST 2014


Filip Pizlo <fpizlo at apple.com> has asked  for review:
Bug 128560: Fail FTL compilation if the required stack is too big
https://bugs.webkit.org/show_bug.cgi?id=128560

Attachment 223765: Patch
https://bugs.webkit.org/attachment.cgi?id=223765&action=review

------- Additional Comments from Filip Pizlo <fpizlo at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=223765&action=review


> Source/JavaScriptCore/ftl/FTLStackMaps.h:104
> +    unsigned getStackSize() const;

I would call this stackSize() and not getStackSize().  We don't usually prepend
getters with "get".  The reason why "getRecordMap()" has a "get" in it is that
it actually has to do significant work to return the record map.  Probably,
that should be called "computeRecordMap()".  But your "getStackSize" is not
computing anything, and it's a getter, so lets just call it "stackSize()".


More information about the webkit-reviews mailing list