[webkit-reviews] review granted: [Bug 128295] [WK2] Add the minimumLayoutSizeOverride SPI to WKWebView : [Attachment 223301] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Feb 5 21:36:49 PST 2014


Anders Carlsson <andersca at apple.com> has granted Benjamin Poulain
<benjamin at webkit.org>'s request for review:
Bug 128295: [WK2] Add the minimumLayoutSizeOverride SPI to WKWebView
https://bugs.webkit.org/show_bug.cgi?id=128295

Attachment 223301: Patch
https://bugs.webkit.org/attachment.cgi?id=223301&action=review

------- Additional Comments from Anders Carlsson <andersca at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=223301&action=review


> Source/WebKit2/UIProcess/API/Cocoa/WKWebViewPrivate.h:26
> +#import "WKWebView.h"

This should be #import <WebKit2/WKWebView.h>.

> Source/WebKit2/UIProcess/API/Cocoa/WKWebViewPrivate.h:30
> + at interface WKWebView (Private)

The category name should be WKPrivate here.

> Source/WebKit2/UIProcess/API/Cocoa/WKWebViewPrivate.h:33
> + at property (nonatomic) CGSize minimumLayoutSizeOverride;

We've decided to use underscores for SPI methods. This should be something
like:

@property (nonatomic setter=_setMinimumLayoutSizeOverride:) CGSize
_minimumLayoutSizeOverride;

and the getters and setters should be named appropriately.


More information about the webkit-reviews mailing list