[webkit-reviews] review granted: [Bug 128036] Subpixel rendering: Make BorderEdge/RoundedRect::Radii LayoutUnit aware. : [Attachment 222875] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Feb 1 08:12:53 PST 2014


Darin Adler <darin at apple.com> has granted Zalan Bujtas <zalan at apple.com>'s
request for review:
Bug 128036: Subpixel rendering: Make BorderEdge/RoundedRect::Radii LayoutUnit
aware.
https://bugs.webkit.org/show_bug.cgi?id=128036

Attachment 222875: Patch
https://bugs.webkit.org/attachment.cgi?id=222875&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=222875&action=review


> Source/WebCore/rendering/RenderBoxModelObject.cpp:1459
>	   if (fullWidth % 3 == 2)
> -	       outerWidth += 1;
> +	       outerWidth += LayoutUnit::fromPixel(1);
>  
>	   if (fullWidth % 3 == 1)
> -	       innerWidth += 1;
> +	       innerWidth += LayoutUnit::fromPixel(1);
>      }

Why is this change needed? There’s a += operator on LayoutUnit that works with
integers and does fromPixel, right?

> Source/WebCore/rendering/RenderBoxModelObject.cpp:2064
> +		   LayoutUnit inflateValue = LayoutUnit::fromPixel(1);
> +		   outerBorderTopWidth+= inflateValue;
> +		   outerBorderBottomWidth+= inflateValue;
> +		   outerBorderLeftWidth+= inflateValue;
> +		   outerBorderRightWidth+= inflateValue;

Why does this need to change at all? LayoutUnit already has an operator++ that
should do the right thing.

Also, formatting mistakes here.


More information about the webkit-reviews mailing list