[webkit-reviews] review granted: [Bug 131813] Add SPI to see if web process is live or got killed : [Attachment 229572] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Apr 17 13:53:26 PDT 2014


Anders Carlsson <andersca at apple.com> has granted Pratik Solanki
<psolanki at apple.com>'s request for review:
Bug 131813: Add SPI to see if web process is live or got killed
https://bugs.webkit.org/show_bug.cgi?id=131813

Attachment 229572: Patch
https://bugs.webkit.org/attachment.cgi?id=229572&action=review

------- Additional Comments from Anders Carlsson <andersca at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=229572&action=review


> Source/WebKit2/UIProcess/API/Cocoa/WKWebView.mm:1411
> +- (BOOL)_isValid
> +{
> +    return _page->isValid();
> +}

I think this name is too generic. How about _hasWebProcess?

> Source/WebKit2/UIProcess/API/Cocoa/WKWebViewPrivate.h:121
> +- (BOOL)_isValid;

This should be a property.


More information about the webkit-reviews mailing list