[webkit-reviews] review granted: [Bug 122081] FTL: refactor compileAdd and compileArithSub into one function. : [Attachment 212947] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sun Sep 29 21:50:43 PDT 2013


Geoffrey Garen <ggaren at apple.com> has granted Nadav Rotem <nrotem at apple.com>'s
request for review:
Bug 122081: FTL: refactor compileAdd and compileArithSub into one function.
https://bugs.webkit.org/show_bug.cgi?id=122081

Attachment 212947: Patch
https://bugs.webkit.org/attachment.cgi?id=212947&action=review

------- Additional Comments from Geoffrey Garen <ggaren at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=212947&action=review


> Source/JavaScriptCore/ftl/FTLLowerDFGToLLVM.cpp:660
> +    void compileAddSub(AddOrSubKind OpKind)
>      {
> +	   bool isSub = OpKind == Sub;

Sorry to keep going with the style nits, but the "O" in "OpKind" should be
lower case.

I'm going to r+ this patch. Can you post a follow-up to fix the "O"?


More information about the webkit-reviews mailing list