[webkit-reviews] review granted: [Bug 121161] Rework CSS parser, eliminating "floating" concept and using %destructor : [Attachment 211314] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 11 09:23:57 PDT 2013


Antti Koivisto <koivisto at iki.fi> has granted Darin Adler <darin at apple.com>'s
request for review:
Bug 121161: Rework CSS parser, eliminating "floating" concept and using
%destructor
https://bugs.webkit.org/show_bug.cgi?id=121161

Attachment 211314: Patch
https://bugs.webkit.org/attachment.cgi?id=211314&action=review

------- Additional Comments from Antti Koivisto <koivisto at iki.fi>
View in context: https://bugs.webkit.org/attachment.cgi?id=211314&action=review


r=me

> Source/WebCore/css/CSSGrammar.y.in:188
> +%union { StyleRuleBase* rule; }

Is there still no way to use safe types in grammar? All these leakRefs and
leakPtrs are bit scary.

>>>> Source/WebCore/css/CSSParser.cpp:11744
>>>> +	  specifiers->appendTagHistory(CSSSelector::SubSelector,
newSpecifier.release());
>>> 
>>> The return type should use PassOwnPtr instead of OwnPtr. 
[readability/pass_ptr] [5]
>> 
>> The parameter type should use PassOwnPtr instead of OwnPtr. 
[readability/pass_ptr] [5]
> 
> The parameter type should use PassOwnPtr instead of OwnPtr. 
[readability/pass_ptr] [5]

style bot needs to learn that PassOwnPtr is obsolete


More information about the webkit-reviews mailing list