[webkit-reviews] review granted: [Bug 120684] Simplify subtree relayout scheduling a bit. : [Attachment 210462] Patch idea.

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Sep 4 09:08:59 PDT 2013


Antti Koivisto <koivisto at iki.fi> has granted Andreas Kling <akling at apple.com>'s
request for review:
Bug 120684: Simplify subtree relayout scheduling a bit.
https://bugs.webkit.org/show_bug.cgi?id=120684

Attachment 210462: Patch idea.
https://bugs.webkit.org/attachment.cgi?id=210462&action=review

------- Additional Comments from Antti Koivisto <koivisto at iki.fi>
View in context: https://bugs.webkit.org/attachment.cgi?id=210462&action=review


> Source/WebCore/page/FrameView.cpp:2445
> +    if (m_layoutRoot == &relayoutRoot)
> +	   return;

The argument could use a better name. newLayoutRoot?

> Source/WebCore/page/FrameView.cpp:2466
> +	   InspectorInstrumentation::didInvalidateLayout(&frame());

There is some repetition with this. I wonder if splitting this up to two
functions would look nicer. The inner one would return bool if it actually did
invalidate layout for example.


More information about the webkit-reviews mailing list