[webkit-reviews] review granted: [Bug 123401] RenderElement::m_style should be a Ref. : [Attachment 215300] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Oct 28 06:57:52 PDT 2013


Antti Koivisto <koivisto at iki.fi> has granted Andreas Kling <akling at apple.com>'s
request for review:
Bug 123401: RenderElement::m_style should be a Ref.
https://bugs.webkit.org/show_bug.cgi?id=123401

Attachment 215300: Patch
https://bugs.webkit.org/attachment.cgi?id=215300&action=review

------- Additional Comments from Antti Koivisto <koivisto at iki.fi>
View in context: https://bugs.webkit.org/attachment.cgi?id=215300&action=review


> Source/WebCore/rendering/RenderElement.cpp:415
> +    Ref<RenderStyle> oldStyle(std::move(style));
> +    m_style.swap(oldStyle);

It is bit misleading that you put the new style to a variable called oldStyle.
Might API that would work like

Ref<RenderStyle> oldStyle(m_style.swap(std::move(style)))

be better?


More information about the webkit-reviews mailing list