[webkit-reviews] review granted: [Bug 123201] [WK2] [GTK] Allow running the web process with an arbitrary prefix command : [Attachment 215287] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Oct 28 01:39:15 PDT 2013


Carlos Garcia Campos <cgarcia at igalia.com> has granted Alberto Garcia
<berto at igalia.com>'s request for review:
Bug 123201: [WK2] [GTK] Allow running the web process with an arbitrary prefix
command
https://bugs.webkit.org/show_bug.cgi?id=123201

Attachment 215287: Patch
https://bugs.webkit.org/attachment.cgi?id=215287&action=review

------- Additional Comments from Carlos Garcia Campos <cgarcia at igalia.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=215287&action=review


This looks good to me. Thanks.

> Source/WebKit2/UIProcess/Launcher/gtk/ProcessLauncherGtk.cpp:105
> +    if (!m_launchOptions.processCmdPrefix.isEmpty()) {

You are preventing this from being empty in
WebProcessProxy::platformGetLaunchOptions, so we could probably check whether
it's null instead.

> Source/WebKit2/UIProcess/Launcher/gtk/ProcessLauncherGtk.cpp:106
> +	   Vector<String> splitted;

I'm not an English expert at all, but I think splitted doesn't exists. We could
call this something like splitArgs or splitPrefixArgs


More information about the webkit-reviews mailing list