[webkit-reviews] review granted: [Bug 86914] Enable webaudio/ tests on DRT/Mac. : [Attachment 214682] proposed patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Oct 19 19:54:11 PDT 2013


Darin Adler <darin at apple.com> has granted Alexey Proskuryakov <ap at webkit.org>'s
request for review:
Bug 86914: Enable webaudio/ tests on DRT/Mac.
https://bugs.webkit.org/show_bug.cgi?id=86914

Attachment 214682: proposed patch
https://bugs.webkit.org/attachment.cgi?id=214682&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=214682&action=review


> Tools/DumpRenderTree/TestRunner.cpp:341
> +    JSC::JSArrayBufferView* jsBufferView =
JSC::jsDynamicCast<JSC::JSArrayBufferView*>(toJS(toJS(context), arguments[0]));


Maybe bufferViewWrapper would be a  better name for this local variable?

> Tools/DumpRenderTree/TestRunner.cpp:344
> +    const char* buffer = (const char*)bufferView->baseAddress();

Why a C-style cast? Can we use static_cast or const_cast or reinterpret_cast?


More information about the webkit-reviews mailing list