[webkit-reviews] review granted: [Bug 122539] Rename EventRetargeter::adjustForRelatedTarget to EventPath::setRelatedTarget : [Attachment 213748] Cleanup

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Oct 8 22:21:48 PDT 2013


Darin Adler <darin at apple.com> has granted Ryosuke Niwa <rniwa at webkit.org>'s
request for review:
Bug 122539: Rename EventRetargeter::adjustForRelatedTarget to
EventPath::setRelatedTarget
https://bugs.webkit.org/show_bug.cgi?id=122539

Attachment 213748: Cleanup
https://bugs.webkit.org/attachment.cgi?id=213748&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=213748&action=review


> Source/WebCore/dom/Event.h:175
> +    virtual EventTarget* relatedTarget() const { return 0; }

nullptr

> Source/WebCore/dom/MouseEvent.cpp:210
> +	   return target ? target->toNode() : 0;

nullptr

But also, not sure why you are putting this into a local variable and not
putting target() below into one. It’s especially confusing to put this into a
local variable named target, when there’s a function by that name that would
return something different.

> Source/WebCore/dom/MouseEvent.cpp:213
>      return target() ? target()->toNode() : 0;

nullptr

> Source/WebCore/dom/MouseEvent.cpp:221
> +	   return target ? target->toNode() : 0;

nullptr

> Source/WebCore/dom/MouseEvent.cpp:224
>      return target() ? target()->toNode() : 0;

nullptr


More information about the webkit-reviews mailing list