[webkit-reviews] review granted: [Bug 124793] CodeBlock::m_numCalleeRegisters shouldn't also mean frame size, frame size needed for exit, or any other unrelated things : [Attachment 217719] the patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Nov 22 15:32:39 PST 2013


Mark Hahnenberg <mhahnenberg at apple.com> has granted Filip Pizlo
<fpizlo at apple.com>'s request for review:
Bug 124793: CodeBlock::m_numCalleeRegisters shouldn't also mean frame size,
frame size needed for exit, or any other unrelated things
https://bugs.webkit.org/show_bug.cgi?id=124793

Attachment 217719: the patch
https://bugs.webkit.org/attachment.cgi?id=217719&action=review

------- Additional Comments from Mark Hahnenberg <mhahnenberg at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=217719&action=review


r=me

> Source/JavaScriptCore/dfg/DFGGraph.cpp:709
> +    unsigned count = m_profiledBlock->m_numCalleeRegisters;

JIT::frameRegisterCountFor(m_profiledBlock)

> Source/JavaScriptCore/dfg/DFGGraph.cpp:713
> +	   unsigned requiredCount =
VirtualRegister(inlineCallFrame->stackOffset).toLocal() + 1 +
codeBlock->m_numCalleeRegisters;

JIT::frameRegisterCountFor(codeBlock)

> Source/JavaScriptCore/dfg/DFGGraph.cpp:715
> +	   if (requiredCount > count)
> +	       count = requiredCount;

max?


More information about the webkit-reviews mailing list