[webkit-reviews] review granted: [Bug 124666] Simple line layout should support floats : [Attachment 217459] patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 20 12:44:47 PST 2013


Dave Hyatt <hyatt at apple.com> has granted Antti Koivisto <koivisto at iki.fi>'s
request for review:
Bug 124666: Simple line layout should support floats
https://bugs.webkit.org/show_bug.cgi?id=124666

Attachment 217459: patch
https://bugs.webkit.org/attachment.cgi?id=217459&action=review

------- Additional Comments from Dave Hyatt <hyatt at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=217459&action=review


r=me. I'm a bit concerned about all the physical naming though. This layout
should obviously work with vertical text too, so the naming needs to be a bit
less writing-mode-biased.

> Source/WebCore/rendering/SimpleLineLayoutResolver.h:111
> +    const LayoutUnit m_topBorderAndPadding;

Rename this to m_beforeBorderAndPadding.

> Source/WebCore/rendering/SimpleLineLayoutResolver.h:179
>      float baselineY = resolver.m_lineHeight * m_iterator.lineIndex() +
resolver.m_baseline;

Would be nice if this "baselineY" didn't contain "Y" since it's horizontal for
vertical text... Maybe just baselinePosition or baselineOffset?

> Source/WebCore/rendering/SimpleLineLayoutResolver.h:256
> +    , m_topBorderAndPadding(flow.borderTop() + flow.paddingTop())

Shouldn't this be 'before" rather than "top"?


More information about the webkit-reviews mailing list