[webkit-reviews] review granted: [Bug 124212] Modifying RTCSessionDescription object construction to match the spec : [Attachment 216803] Rebased patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Nov 13 10:04:53 PST 2013


Eric Carlson <eric.carlson at apple.com> has granted Thiago de Barros Lacerda
<thiago.lacerda at openbossa.org>'s request for review:
Bug 124212: Modifying RTCSessionDescription object construction to match the
spec
https://bugs.webkit.org/show_bug.cgi?id=124212

Attachment 216803: Rebased patch
https://bugs.webkit.org/attachment.cgi?id=216803&action=review

------- Additional Comments from Eric Carlson <eric.carlson at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=216803&action=review


> Source/WebCore/ChangeLog:13
> +	   According to the spec the RTCSessionDescriptionInit parameter in
RTCSessionDescription constructor is optional,
> +	   which must not be nullable.
> +	   If the 'type' and/or 'sdp' keys are not present, the string object
that stores them in the
> +	   RTCSessionDescription class, must be null in those cases.
> +	   Also, if an object that is not a Dictionary is passed as argument to
the constructor, an exception must be
> +	   raised.

Nit: I don't think the line breaks after each sentence aid readability. I would
remove them.

> Source/WebCore/bindings/js/JSRTCSessionDescriptionCustom.cpp:46
> +	       return throwVMError(exec, createTypeError(exec, "Optional
description init argument of RTCSessionDescription must be a valid
Dictionary"));

Nit: I would change this to "Optional RTCSessionDescription constructor
argument must be a valid Dictionary"


More information about the webkit-reviews mailing list