[webkit-reviews] review granted: [Bug 121079] structure of frame tree is not correct in WINCE port. : [Attachment 215725] updated patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Nov 1 11:51:07 PDT 2013


Darin Adler <darin at apple.com> has granted Zhuang Zhigang
<zhuangzg at cn.fujitsu.com>'s request for review:
Bug 121079: structure of frame tree is not correct in WINCE port.
https://bugs.webkit.org/show_bug.cgi?id=121079

Attachment 215725: updated patch
https://bugs.webkit.org/attachment.cgi?id=215725&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=215725&action=review


> Source/WebKit/wince/WebView.cpp:159
>  PassRefPtr<Frame> WebView::createFrame(const URL& url, const String& name,
HTMLFrameOwnerElement* ownerElement, const String& referrer,
> -					  bool /*allowsScrolling*/, int
/*marginWidth*/, int /*marginHeight*/)
> +    bool /*allowsScrolling*/, int /*marginWidth*/, int /*marginHeight*/,
Frame* frame)

Argument should be named parentFrame.

> Source/WebKit/wince/WebView.h:72
> +    PassRefPtr<WebCore::Frame> createFrame(const WebCore::URL&, const
WTF::String&, WebCore::HTMLFrameOwnerElement*, const WTF::String&, bool, int,
int, WebCore::Frame*);

Should give the arguments names here, except the ones that are obvious from the
type along. The meanings of the strings, bool, ints, and frame are not obvious.


More information about the webkit-reviews mailing list