[webkit-reviews] review granted: [Bug 117015] Expose incrementalRenderingSuppressionTimeoutInSeconds via WK2 : [Attachment 203311] patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed May 29 23:13:06 PDT 2013


Darin Adler <darin at apple.com> has granted Tim Horton
<timothy_horton at apple.com>'s request for review:
Bug 117015: Expose incrementalRenderingSuppressionTimeoutInSeconds via WK2
https://bugs.webkit.org/show_bug.cgi?id=117015

Attachment 203311: patch
https://bugs.webkit.org/attachment.cgi?id=203311&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=203311&action=review


> Source/WebKit2/UIProcess/API/C/WKPreferencesPrivate.h:286
> +// Defaults to 5 seconds

We put periods on these kinds of fragments, usually.

> Source/WebKit2/UIProcess/API/C/WKPreferencesPrivate.h:288
> +WK_EXPORT void
WKPreferencesSetIncrementalRenderingSuppressionTimeoutInSeconds(WKPreferencesRe
f preferencesRef, double timeout);
> +WK_EXPORT double
WKPreferencesGetIncrementalRenderingSuppressionTimeoutInSeconds(WKPreferencesRe
f preferencesRef);

Does “in seconds” really need to be in the function name? We use seconds for
all our WebKit time units, don’t we? And it’s also the standard in Cocoa. Maybe
the argument name would be sufficient?


More information about the webkit-reviews mailing list