[webkit-reviews] review denied: [Bug 115888] [BlackBerry] Unable to download blob resource : [Attachment 201784] update patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed May 15 01:04:24 PDT 2013


Benjamin Poulain <benjamin at webkit.org> has denied Mary Wu
<mary.wu at torchmobile.com.cn>'s request for review:
Bug 115888: [BlackBerry] Unable to download blob resource
https://bugs.webkit.org/show_bug.cgi?id=115888

Attachment 201784: update patch
https://bugs.webkit.org/attachment.cgi?id=201784&action=review

------- Additional Comments from Benjamin Poulain <benjamin at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=201784&action=review


> Source/WebCore/platform/network/blackberry/BlobStream.h:36
> +    // From class BlackBerry::Platform::FilterStream

Missing period.

> Source/WebCore/platform/network/blackberry/BlobStream.h:38
> +    virtual BlackBerry::Platform::String url() const;
> +    virtual const BlackBerry::Platform::String mimeType() const;

Missing OVERRIDE.

> Source/WebCore/platform/network/blackberry/BlobStream.h:40
> +    // From class ResourceHandleClient

Missing period.

> Source/WebCore/platform/network/blackberry/BlobStream.h:43
> +    virtual void didReceiveData(ResourceHandle*, const char*, int, int
/*encodedDataLength*/);
> +    virtual void didFinishLoading(ResourceHandle*, double /*finishTime*/);
> +    virtual void didFail(ResourceHandle*, const ResourceError&);

Missing override + don't put variable names into comments like that.

> Source/WebKit/blackberry/WebCoreSupport/FrameLoaderClientBlackBerry.cpp:1220
> +	       NetworkRequest req;

req is a bad variable name.

> Source/WebKit/blackberry/WebCoreSupport/FrameLoaderClientBlackBerry.cpp:1221
> +	      
req.setRequestUrl(BlackBerry::Platform::String::fromUtf8(request.url().string()
.utf8().data()));

There is an implicit conversion operator for String ->
BlackBerry::Platform::String.


More information about the webkit-reviews mailing list